mirror of
https://codeberg.org/jopejoe1/nix-conf.git
synced 2024-12-29 18:36:51 +01:00
35 lines
752 B
Nix
35 lines
752 B
Nix
{
|
|
config,
|
|
lib,
|
|
modulesPath,
|
|
...
|
|
}:
|
|
|
|
{
|
|
imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
|
|
|
|
boot.initrd.availableKernelModules = [
|
|
"xhci_pci"
|
|
"ehci_pci"
|
|
"ahci"
|
|
"usb_storage"
|
|
"sd_mod"
|
|
"sr_mod"
|
|
"sdhci_pci"
|
|
"rtsx_pci_sdmmc"
|
|
];
|
|
boot.initrd.kernelModules = [ ];
|
|
boot.kernelModules = [ "kvm-intel" ];
|
|
boot.extraModulePackages = [ ];
|
|
|
|
fileSystems."/" = {
|
|
device = "/dev/disk/by-uuid/1cae8f88-5db6-4c97-88e4-350c35275d5c";
|
|
fsType = "ext4";
|
|
};
|
|
|
|
swapDevices = [ { device = "/dev/disk/by-uuid/8569ee66-b939-4ce8-a94a-dca7df5e301b"; } ];
|
|
|
|
networking.useDHCP = lib.mkDefault true;
|
|
|
|
hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
|
|
}
|