mirror of
https://codeberg.org/jopejoe1/nix-conf.git
synced 2024-12-29 18:06:50 +01:00
16 lines
233 B
Nix
16 lines
233 B
Nix
{ config, lib, ... }:
|
|
|
|
let
|
|
cfg = config.jopejoe1.sway;
|
|
in
|
|
{
|
|
options.jopejoe1.sway = {
|
|
enable = lib.mkEnableOption "Enable Sway";
|
|
};
|
|
|
|
config = lib.mkIf cfg.enable {
|
|
programs.sway = {
|
|
enable = true;
|
|
};
|
|
};
|
|
}
|