mirror of
https://codeberg.org/jopejoe1/nix-conf.git
synced 2024-12-29 18:06:50 +01:00
27 lines
420 B
Nix
27 lines
420 B
Nix
{
|
|
config,
|
|
lib,
|
|
pkgs,
|
|
self,
|
|
...
|
|
}:
|
|
|
|
let
|
|
cfg = config.jopejoe1.ssh;
|
|
in
|
|
{
|
|
options.jopejoe1.ssh = {
|
|
enable = lib.mkEnableOption "Enable ssh";
|
|
};
|
|
|
|
config = lib.mkIf cfg.enable {
|
|
services.openssh = {
|
|
enable = true;
|
|
banner = "Hackers are in Your System!!!\n";
|
|
settings = {
|
|
PasswordAuthentication = false;
|
|
PermitRootLogin = "prohibit-password";
|
|
};
|
|
};
|
|
};
|
|
}
|