mirror of
https://codeberg.org/jopejoe1/nix-conf.git
synced 2024-12-29 17:46:52 +01:00
36 lines
549 B
Nix
36 lines
549 B
Nix
{
|
|
config,
|
|
lib,
|
|
pkgs,
|
|
...
|
|
}:
|
|
|
|
let
|
|
cfg = config.jopejoe1.printing;
|
|
in
|
|
{
|
|
options.jopejoe1.printing = {
|
|
enable = lib.mkEnableOption "Enable Printing";
|
|
};
|
|
|
|
config = lib.mkIf cfg.enable {
|
|
services.printing = {
|
|
enable = true;
|
|
webInterface = true;
|
|
drivers = with pkgs; [ ];
|
|
};
|
|
|
|
hardware = {
|
|
sane = {
|
|
enable = true;
|
|
extraBackends = with pkgs; [ sane-airscan ];
|
|
};
|
|
};
|
|
|
|
services.avahi = {
|
|
enable = true;
|
|
nssmdns4 = true;
|
|
openFirewall = true;
|
|
};
|
|
};
|
|
}
|