mirror of
https://codeberg.org/jopejoe1/nix-conf.git
synced 2025-01-01 16:26:51 +01:00
26 lines
479 B
Nix
26 lines
479 B
Nix
{ config, lib, ... }:
|
|
|
|
let
|
|
cfg = config.jopejoe1.boot.systemd;
|
|
in
|
|
{
|
|
options.jopejoe1.boot.systemd = {
|
|
enable = lib.mkEnableOption "Enable Systemd boot";
|
|
};
|
|
|
|
config = lib.mkIf cfg.enable {
|
|
boot = {
|
|
loader = {
|
|
systemd-boot = {
|
|
enable = true;
|
|
configurationLimit = 10;
|
|
editor = false;
|
|
};
|
|
efi = {
|
|
canTouchEfiVariables = true;
|
|
efiSysMountPoint = "/boot";
|
|
};
|
|
};
|
|
};
|
|
};
|
|
}
|