mirror of
https://codeberg.org/jopejoe1/nix-conf.git
synced 2024-12-29 18:06:50 +01:00
34 lines
558 B
Nix
34 lines
558 B
Nix
{
|
|
config,
|
|
lib,
|
|
pkgs,
|
|
...
|
|
}:
|
|
|
|
let
|
|
cfg = config.jopejoe1.git;
|
|
in
|
|
{
|
|
options.jopejoe1.git = {
|
|
enable = lib.mkEnableOption "Enable Git";
|
|
};
|
|
|
|
config = lib.mkIf cfg.enable {
|
|
programs.lazygit.enable = true;
|
|
programs.git = {
|
|
enable = true;
|
|
package = pkgs.git;
|
|
userEmail = "johannes@joens.email";
|
|
userName = "jopejoe1";
|
|
extraConfig = {
|
|
core = {
|
|
whitespace = [
|
|
"blank-at-eol"
|
|
"blank-at-eof"
|
|
"space-before-tab"
|
|
];
|
|
};
|
|
};
|
|
};
|
|
};
|
|
}
|