nix-conf/home-modules/git/default.nix
2024-07-10 23:02:54 +02:00

34 lines
558 B
Nix

{
config,
lib,
pkgs,
...
}:
let
cfg = config.jopejoe1.git;
in
{
options.jopejoe1.git = {
enable = lib.mkEnableOption "Enable Git";
};
config = lib.mkIf cfg.enable {
programs.lazygit.enable = true;
programs.git = {
enable = true;
package = pkgs.git;
userEmail = "johannes@joens.email";
userName = "jopejoe1";
extraConfig = {
core = {
whitespace = [
"blank-at-eol"
"blank-at-eof"
"space-before-tab"
];
};
};
};
};
}