20 lines
635 B
Nix
20 lines
635 B
Nix
{
|
|
description = "A Nix-flake-based Python development environment";
|
|
|
|
inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
|
|
|
|
outputs = { self, nixpkgs }:
|
|
let
|
|
forEachSupportedSystem = f: nixpkgs.lib.genAttrs nixpkgs.lib.systems.flakeExposed (system: f {
|
|
pkgs = import nixpkgs { inherit system; };
|
|
});
|
|
in
|
|
{
|
|
devShells = forEachSupportedSystem ({ pkgs }: {
|
|
default = pkgs.mkShell {
|
|
packages = with pkgs; [ python311 virtualenv libffi libsodium jetbrains.pycharm-community ] ++
|
|
(with pkgs.python311Packages; [ pip virtualenv ]);
|
|
};
|
|
});
|
|
};
|
|
}
|